Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Full rev problem after FIP and injectors recon'd
09-09-2016, 09:08 AM (This post was last modified: 09-09-2016 09:44 AM by Cornish Rattler.)
Post: #1
Full rev problem after FIP and injectors recon'd
Hi guys

This is my first main post so be easy on me, anyway long story I own a 1988 Land Rover Defender was a 2.5TD but now a Discovery 200TDI.

I bought the 200tdi engine off eBay as an engine that was fully recon'd 4 years ago but stored in a garage for the past 2 years so should still be in good con'd, anyway I part stripped the the engine just to be certain the engine was as it was supposed to be which it was so I replaced all gaskets and seals and swapped the engine over, after fitting the engine I came to start it and after bleeding the fuel system the engine fired up immediately and ran great, anyway then I tried to rev the engine ( stationary ) and the lever / linkage on the FIP would only go 3/4 the way to the Rev stop screw then the engine would refer img die, allow the linkage to return to the idle screw and the engine would idle, so I took the vehicle out round the block a couple of time to see if I could sort it but couldn't and resigned myself to the fact that the FIP and injectors needed referbing so last week I have them referbished and took the vehicle for a run and although it ran better as now it revs better now ( FIP set to top end power ) I find when climbing hills the engine still tries to die when at full revs going through the gears and having to change gear before I need to to stop it from dying on me.

So I am thinking could this problem be a turbo problem rather than a FIP problem, what do you think
______________
Graham

Graham
Find all posts by this user
Quote this message in a reply
09-09-2016, 08:04 PM
Post: #2
RE: Full rev problem after FIP and injectors recon'd
Hi,

From what you describe it is not a turbo problem , I would suggest you have a look at your diesel filter to see if it is clogged , otherwise to me it sounds like a fuel related problem.
Find all posts by this user
Quote this message in a reply
09-09-2016, 09:51 PM
Post: #3
RE: Full rev problem after FIP and injectors recon'd
Are right ok when they stripped the FIP down they said it was all slugged up inside and said when the replaced the fuel filter they found some brown stuff on the top of the filter now I have recently completed a new chassis rebuild which inc a new fuel tank and filter so I am not sure what it is or how it's got in there.

Ok I am off this week so I will drain, check and clean the tank out and change the filter and see how I get on

Cheers Hot_Rod

Graham
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump:


User(s) browsing this thread: 1 Guest(s)